[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: make in pbuilder error

> Od: Neil Williams <codehelp@debian.org>

NW> > > You need to work out which library (libfoo.so) contains the undefined
NW> > > references and ensure that the objects are linked against them.

JM> > I've tried. Is there some good way how find library with these referencies?

NW> grep
NW> If it's a packaged library, it will be in /usr/lib/ or a directory
NW> beneath that.

I installed this source even in chroot without problems when I've installed dependencies.
After greping undefined references I've found that these references includes library I am just building.

root@64studio:~/chroot/sid# find /home/mira/chroot/sid/usr/lib -type f -exec grep -l "dynparam_ui_group_disappeared" {} \;

I've tried this on other system and in chroot too.

That is making me even more confused.

Source has 4 subdirs: config, debian, host, plugin.
host and plugin has each their own makefile.in and makefile.am

Changing this somehow situation?



Reply to: