[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: phpmyid



OoO En ce début d'après-midi  ensoleillé du samedi 26 juillet 2008, vers
15:38, Andreas Schildbach <andreas@schildbach.de> disait :

> The package can be found on mentors.debian.net:
> - URL: http://mentors.debian.net/debian/pool/main/p/phpmyid
> - Source repository: deb-src http://mentors.debian.net/debian unstable
> main contrib non-free
> - dget
> http://mentors.debian.net/debian/pool/main/p/phpmyid/phpmyid_0.9-1.dsc

In debian/changelog,  remove the mention  about this package  being your
first. Most users are not interested in thisinformation.

In debian/control, your dependencies  are too strict. For the webserver,
depend on  apache2 | httpd. People  using lighttpd can  use your package
too, for  example. Instead of libapache2-mod-php5, depend  on php5: even
Apache2  users may  prefer to  use fcgi  for example  and  not mod-php5;
moreover,  this way,  you allow  user of  other webservers  to  not pull
Apache2.

Maybe, you can add a word about OpenID in the long description.

The last sentence in debian/copyright is wider than 80 characters.

I think that you should not ship htaccess file (or as documentation). It
is  usually better  to  put all  configuration  in Apache  configuration
file.  For example,  by default,  rewrite  rules are  not authorized  in
htaccess. You can put the  content of htaccess in your apache2.conf file
for example.

Cleanup debian/watch.

You   depend  on   debhelper   7  but   you   don't  use   any  of   its
functionalities. You can use debhelper 5 instead.

The package seems fine otherwise.
-- 
BOFH excuse #160:
non-redundant fan failure

Attachment: pgpeIXGoX3f3W.pgp
Description: PGP signature


Reply to: