[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

piuparts and sarge

Dear mentors,

I run sarge on my box. I got pbuilder from backports to sid-compile, but
piuparts is not on backports (presumably due to an unmeetable dependency
on python IIRC). So I run piuparts in a sid chroot. Is it the only/right
way to go? I have to say I had to downgrade tar to sarge's version in
the chroot for piuparts to work (due to #377785), am I the only one
experiencing this problem?

I'm also not sure how to be certain piuparts terminates with a "go"
answer: currently it terminates by listing lsof errors due to mount
points that exist in the host but not in the (sid) chroot. IMHO, this
information should not be available from within the chroot, but it is by
means of /proc/mounts (my fstab line reads
proc-sid /data/sid-chroot/proc proc none 0 0

I'd like piuparts to finish with a synthetic report such as "such and
such tests successfully attempted: no spurious file left" or "such and
such files remained after purge".

Best regards, Thibaut.

Reply to: