[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dependancies within multi-binary packages


I am building some multi-binary packages. The packages contain libraries
that other packages in the same build will depend on. Because the
packages I am building potentially conflict with some already in the
repository I have renamed them all with an extenstion denoting their
purpose. In the control file I am setting the "Conflicts" and "Provides"
to turn the libraries into "virtual packages" and  using
"${shlibs:Depends}" to define lib requirements. When I install my custom
libs dpkg does not seem to recognise the "Provides" section and tells me
that required libs are not installed -

>From control file:

   Package: libpq4-hw
   Architecture: any
   Section: hw/libs
   Depends: ${shlibs:Depends}
   Conflicts: libpq4
   Provides: libpq4
   Description: PostgreSQL C client library

   Package: postgresql-client-8.0-hw
   Architecture: any
   Section: misc 
   Depends: ${shlibs:Depends}, postgresql-client-common
   Conflicts: postgresql (<< 7.5), postgresql-client-8.0
   Provides: postgresql-client-8.0
   Description: front-end programs for PostgreSQL 8.0

Once I install the libpq4-hw package dpkg will still complain:

user@host # dpkg -i postgresql-client-8.0-hw_8.0.7-1_i386.deb 
Selecting previously deselected package postgresql-client-8.0-hw.
(Reading database ... 22134 files and directories currently installed.)
Unpacking postgresql-client-8.0-hw (from
postgresql-client-8.0-hw_8.0.7-1_i386.deb) ...
dpkg: dependency problems prevent configuration of
 postgresql-client-8.0-hw depends on libpq4 (>= 8.0.4); however:
  Package libpq4 is not installed.
dpkg: error processing postgresql-client-8.0-hw (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

The dependencies for the client package look like:

 Package: postgresql-client-8.0-hw
 Version: 8.0.7-1
 Section: misc
 Priority: optional
 Architecture: i386
 Depends: libc6 (>= 2.3.2.ds1-21), libpq4 (>= 8.0.4), libreadline5,
zlib1g (>= 1:1.2.1), postgresql-client-common
 Conflicts: postgresql (<< 7.5), postgresql-client-8.0
 Provides: postgresql-client-8.0

Does anyone know how I can fix this one?

Nikolai Lusan
Systems Administrator

Hitwise Pty. Ltd.
Level 7 / 580 St Kilda Road
Melbourne, Victoria 3004
Phone: +61 3 8530 2400
Fax:  +61 3 9529 8907

Worldwide:  •  United States  •  United Kingdom  •  Australia  •  New
Zealand  •  Singapore  •  Hong Kong 

To subscribe to our complimentary monthly newsletter, visit:

The information transmitted may be confidential, is intended only for
the person to which it is addressed, and may not be reviewed,
retransmitted, disseminated or relied upon by any other persons. If you
received this message in error, please contact the sender and destroy
any paper or electronic copies of this message. Any views expressed in
this email communication are those of the individual sender, except
where the sender specifically states otherwise. Hitwise does not
represent, warrant or guarantee that the communication is free of
errors, virus or interference.

Reply to: