[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dependancies within multi-binary packages

On Mon, Jul 03, 2006 at 12:02:24PM +1000, Nikolai Lusan wrote:
> Once I install the libpq4-hw package dpkg will still complain:
> user@host # dpkg -i postgresql-client-8.0-hw_8.0.7-1_i386.deb 
> Selecting previously deselected package postgresql-client-8.0-hw.
> (Reading database ... 22134 files and directories currently installed.)
> Unpacking postgresql-client-8.0-hw (from
> postgresql-client-8.0-hw_8.0.7-1_i386.deb) ...
> dpkg: dependency problems prevent configuration of
> postgresql-client-8.0-hw:
>  postgresql-client-8.0-hw depends on libpq4 (>= 8.0.4); however:
>   Package libpq4 is not installed.

Versioned dependencies cannot be satisfied by Provided packages, AFAIK.

> Does anyone know how I can fix this one?

I strongly suspect that You're Stuffed.  For this sort of thing, I typically
just create my own packages with the same name and cross my fingers that
they don't get into the wild -- worst case, I make my packages depend on
some sort of local dummy package that shouldn't end up in the wider world,
to prevent major problems.

- Matt

Reply to: