[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Request for sponsor: flpsed

On Sat, Aug 13, 2005 at 12:16:31PM +0200, Morten Brix Pedersen wrote:
> >> I already have a flpsed package in unstable. Unfortunately my usual
> >> sponsor, Bill Allombert, is unavailable to do a new upload.
> >>
> >> The new package fixes grave bug #321430 (uninstallable due to C++ ABI
> >> transition).
> >
> > If it fixes it then why don't you close it in changelog entry?
> The package was built before that bug was reported. I had in mind to close
> the bug manually when the package is uploaded. If you want me to re-built
> the package just to update the changelog; I can do that.

Preferred way of closing bugs is proper changelog entry. I added it
> > And how you can be sure that it's gonna be rebuilt with new fltk?
> > Please put proper version in Build-Depends line. It's possible that some
> > autobuilders still have old version of -dev package.
> As far as I know, there is no new devel package. Only the binary depend on
> libfltk1.1 is needed, which will be filled in automatically by shlibs.
> There is nothing to change in build-depends.

You should ensure that proper version will be used yourself. It is possible
that some autobuilders still didn't recompile their libfltk package and old
one will be used. This way some archs will have fixed package (with new
ABI) and some still not. This isn't the case this time, cause all
autobuilders rebuilt their fltk packages, but it's always better to ensure.
I added correct version of needed libfltk to Build-Depends line.
> > You can also bump your Standards-Version. 3.6.2 is actual.
> >
> > `zless /usr/share/doc/debian-policy/upgrading-checklist.txt.gz`
> Thanks. I will do this for the next update of the package, but not now.

> >> The package can be found at:
> >>
> >>     http://wtf.dk/~mbp/my_debs/flpsed/flpsed_0.3.5/
> >>
> >> Thanks.
> >
> > Fix above issues and contact me privately if you still don't have sponsor.
> If you still feel that there is problems with the above mentioned issues,
> please tell me so.

I fixed those issues and uploaded package.


  ,''`.  Bartosz Fenski | mailto:fenio@debian.org | pgp:0x13fefc40 | irc:fEnIo
 : :' :       32-050 Skawina - Glowackiego 3/15 - w. malopolskie - Poland
 `. `'           phone:+48602383548 | proud Debian maintainer and user
   `-          http://skawina.eu.org | jid:fenio@jabber.org | rlu:172001

Attachment: signature.asc
Description: Digital signature

Reply to: