[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dh_shlibdeps question


I will explain fully why I am wondering about this: I am fixing the SDL packages in Debian. Upstream seems to have changed something ( not sure what ), in either SDL or ALSA, that breaks compatibility. Rebuilting SDL against the latest ALSA in Debian ( 1.0.7-3 ) fixes the problem.

However, the depends info generated by dh_shlibdeps is 'libasound2 (>> 1.0.5)', which will cause problems for users who are not using the latest version.

Could I put this in my shlibs.local file, just to be safe:

libasound 2 libasound2 (>= 1.0.7-3)


martin f krafft wrote:

also sprach martin f krafft <madduck@debian.org> [2004.12.15.1554 +0100]:
How about a versioned Build-Depends on libasound-dev (>= 1.0.7) ?

Won't help. See #281390 (thanks, dato).

Reply to: