[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Update-excuses: Makes N non-depending packages uninstallable on ...

* Frank Küster [Mon, 30 Aug 2004 12:55:56 +0200]:

> * Updating tetex-bin makes 3 depending packages uninstallable on
> alpha: jbibtex-bin, jmpost, ptex-bin

  I think you need to ask -release for a hint of tetex-bin/2.0.2-20 and

> This seems to be bogus, because ptex-bin (source package of the three)
> has a versioned depends on tetex-bin that cannot be fullfilled with the
> version in sarge. 

  so that's the message: "if tetex-bin -20 gets installed in testing,
  I'll have to remove ptex-bin, and I'm not going to do that". herein
  the hint.

> * Updating tetex-bin makes 35 non-depending packages uninstallable on
>   alpha: acl2-infix, advi, cdcover, cjk-latex, dvidvi, dvifb, dvilib2,
>   dvilib2-dev, dvilx, dvipdfm-cjk, dvipdfmx, dvipsk-ja, ipe, jtex-bin,
>   latex2rtf, lgrind, libkpathsea-perl, lilypond, lprfax, multex-bin,
>   musixtex, opustex, pdfjam, pmx, sgf2tex, sgmltexi, spawg, spawx11,
>   tetex-bin, tex-guy, tex4ht, texmacs, therion, xdvik-ja, xgdvi

  I think this will solve too with the hint.

> But how can that cause a problem? According to
> http://buildd.debian.org/build.php?arch=&pkg=tetex-bin
> tetex-bin has been built "maybe-successful"ly on all arches.

  it's not the case, but as you may know, "maybe-successful" does not
  mean the package is in the archive for that arch. you want "Installed"
  in <http://people.debian.org/~igloo/status.php?package=tetex-bin>.

> TIA, Frank


Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621
Man is certainly stark mad; he cannot make a flea, yet he makes gods by the
                -- Michel de Montaigne

Reply to: