[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgrade with incompatible conffiles


I'm preparing packages for the new upstream version (2.0.2) of the
Discover hardware detection system (referenced as discover2). The last
version of discover in Debian is 1.5 (referenced as discover1). The name
of the package is discover.

The current discover package contains a conffile /etc/discover.conf. The
new version of discover will contain a conffile with the same name in
the package libdiscover2. The format used for the configuration file is
incompatible between these two version. If no configuration file with
the new format is installed, discover will stop working. 

My question is how to best handle this situation for upgrades. I already
figured out, that libdiscover2 should "Conflicts: discover (<< 2.0)".
But on upgrade dpkg asks if it should install the new version of the
conffile (because discover was not purged and /etc/discover.conf still
exists). Because the package which contains the conffile changed, this
question is even asked if the user did not change /etc/discover.conf.
How can I avoid this question (at least if the file is unchanged)? 

Thanks for your help


Reply to: