[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: error when building package


  I also had the problem of 

dpkg-deb: parse error, in file `debian/tmp/DEBIAN/control' near line 6 package `bloksi':
 `Depends' field, missing package name, or garbage where package name expected
dh_builddeb: command returned error code
make: *** [binary-indep] Error 1

  It seemed to disappear when I put the "Depends" line in the first
paragraph. I kept one copy of the Depends line in the 2nd paragraph;
otherwise no Depends line appears in debian/tmp/DEBIAN/control.

  This is not likely to be the right way of doing things.


The debian/control file :

Source: bloksi
Section: games
Priority: optional
Maintainer: Etienne Grossmann <etienne@isr.ist.utl.pt>
Standards-Version: 3.0.1
Depends: perl, libgtk-perl, libgnome-perl, libgtk-imlib-perl

Package: bloksi
Depends: perl, libgtk-perl, libgnome-perl, libgtk-imlib-perl
Architecture: all
Description: Sliding-blocks puzzle (glotski written in perl)
 Bloksi is a game of sliding-blocks puzzles in which blocks should be
 pushed around to a "goal" position. Nearly a clone -written in perl-
 of "glotski", whose files can be read.

Reply to: