[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: library dependency problem

On Mon, Jul 26, 1999 at 02:19:33AM +0200, Jim Mintha wrote:
> slang1 (<< 1.3), slang1 (>> 1.2.2-0)
> When I took over the slang1 package I failed to notice the
> shlibs that defined the above.  The problem is that version 1.3.x is
> compatible with 1.2.  This leaves me with a number of options:
Hmm, looks like I shouldn't have not filed that wishlist bug on the theory
that maintainer knew what they were doing better then I.

> 2.  Continue to call it slang1 and upload the new version.  It will
> conflict with the old one, replace it and then break the dependencies
> of everything that depends on slang. (note: only breaks the
> dependencies, the packages would otherwise run fine)  Thereby forcing
> everyone else to upgrade their (slang dependent) packages.
This is, IMHO, the best option.  The jed maintainer has been waiting on you
to upgrade so he can package the latest upstream, I know, and all that would
be required is a simple rebuild.  I'd say package away, and file Important
(possibly even Grave, since the package won't install) bugs against
everything depending on libslang1 to let the maintainers know to rebuild.

Is it possible to "Provide: libslang (1.2.99)"?  (Warning: Idle speculation)

	-=- James Mastros
Caveat Emptator: I am not a Developer.  (But I use libslang-using binaries,
if that counts for anything.)

Reply to: