[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ack! "Broken Libc"

On Thu, Jan 07, 1999 at 11:07:24PM +0100, Martin Bialasinski wrote:
> >> "SJC" == Stephen J Carpenter <sjc@delphi.com> writes:
> SJC> and I ran lintian on the xfstt that I uploaded yesterday and it
> SJC> gave a couple of errors that I will be fixing for unstable soon
> SJC> but.,..  it said "compiled with broken libc"
> This must be the infamous "frame-info" thing.
> SJC> Is this a major worry? SHould i delete the package from incomming
> SJC> and investigate?
> I say yes. You have to recompile it later anyway, so better do it
> now. We have also discussed recompiling other packages in slink as
> well, but dropped it because of the time it would take. So
> recompilation is the right way to solve this.

Well xfstt was rejected because of a checksum problem (I have been having
problems with dpkg and NFS mounted partition...solvced it now)

> SJC> Not sure what to do since all it says is "Broken libc" it doesn't
> SJC> say why it is broken or what version is a known not broken one.
> libc6-2.0.7u-7.1 and higher are OK.

I upgraded libc6 and libstdc++2.9 both to the latest...however
I STILL get the error!

I recompiled xfstt (and added a couple of spelling error fixes
in the Docs)...but even with having upgraded libc6 and libc6-dev and

Still has the problem! below is all the info I could think of to

[sjc@Hal xfstt]$ lintian  xfstt_0.9.10-5_i386.deb
E: xfstt: duplicate-updaterc.d-calls-in-postinst xfstt
E: xfstt: duplicate-updaterc.d-calls-in-postrm xfstt
E: xfstt: manpage-for-x11-binary-in-wrong-directory usr/X11R6/bin/xfstt 
E: xfstt: compiled-with-bad-libc usr/X11R6/bin/xfstt
W: xfstt: wrong-name-for-upstream-changelog usr/doc/xfstt/CHANGES
E: xfstt: relative-conffile etc/init.d/xfstt

lintian -i says:

E: xfstt: compiled-with-bad-libc usr/X11R6/bin/xfstt
N:   This file defines or requires `__register_frame_info' as a dynamic
N:   symbol, and is not linked with libstdc++. This means that it was
N:   compiled with a buggy version of libc. It should be recompiled with
N:   the fixed versions, libc6 2.0.7u-6 or higher. (which may not yet be
N:   available; see debian-devel).
N:   This was a problem in the second half of 1998. If you get this tag
N:   much later than that, it may be a different problem. Please check with
N:   the lintian maintainer in that case.

[sjc@Hal xfstt]$ dpkg -s libc6
Package: libc6
Status: install ok installed
Priority: required
Section: base
Installed-Size: 1421
Maintainer: Joel Klecker <glibc-maint@debian.org>
Source: glibc
Version: 2.0.7v-1

[sjc@Hal xfstt-0.9.10]$ ldd xfstt
        libstdc++.so.2.9 => /usr/lib/libstdc++.so.2.9 (0x40010000)
        libm.so.6 => /lib/libm.so.6 (0x40012000)
        libc.so.6 => /lib/libc.so.6 (0x4002d000)
        libstdc++-libc6.0-1.so.2 => /usr/lib/libstdc++-libc6.0-1.so.2 
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

/* -- Stephen Carpenter <sjc@delphi.com> --- <sjc@debian.org>------------ */
"It is difficult to get a man to understand something when his salary 
depends on his not understanding it"
                 -- U. Sinclair

Reply to: