[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: problem with Abyss


It looks like "ABYSS-P" is missing from the "abyss" package:

root@beluga:~# apt policy abyss
  Installed: 2.0.2-3
  Candidate: 2.0.2-3
  Version table:
 *** 2.0.2-3 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages
        100 /var/lib/dpkg/status

Using ABYSS-P with MPI is documented on Salsa:


Is this a similar Ubuntu problem to "metaphlan2", which is still not in Ubuntu-MATE 18.04 LTS?

AFAIK, Ubuntu 18.04 LTS is based on Debian "buster":

root@beluga:~# cat /etc/debian_version buster/sid

Any ideas how to fix it?



Minke Informatics Limited, Registered in Scotland - Company No. SC419028
Registered Office: 3 Donview, Bridge of Alford, AB33 8QJ, Scotland (UK)
tel. +44(0)19755 63548                    http://minke-informatics.co.uk
mob. +44(0)7985 078324        mailto:tony.travis@minke-informatics.co.uk
--- Begin Message ---
Dear Sir/Ms
I recently installed Abyss assembler through the command 

sudo apt-get install abyss
on Ubuntu Mate release 18.04.2 LTS (Bionic Beaver) 64-bit. However when I run Abyss-pe with the small sample data suggested in Githup bcgsc/abyss as default command "abyss-pe k=25 name=test in='test-data/reads1.fastq test-data/reads2.fastq'" it work fine but when I tried to use Parallel processing with 16 threads using the following command   
"abyss-pe k=25 np=16 name=test in='test-data/reads1.fastq test-data/reads2.fastq" it failed and gave me this error 

adly@bioann:~$ abyss-pe k=25 np=16 name=test in='test-data/reads1.fastq test-data/reads2.fastq'
/usr/bin/mpirun -np 16 ABYSS-P -k25 -q3    --coverage-hist=coverage.hist -s test-bubbles.fa  -o test-1.fa test-data/reads1.fastq test-data/reads2.fastq 
mpirun was unable to find the specified executable file, and therefore
did not launch the job.  This error was first reported for process
rank 0; it may have occurred for other processes as well.

NOTE: A common cause for this error is misspelling a mpirun command
      line parameter option (remember that mpirun interprets the first
      unrecognized command line token as the executable).

Node:       bioann
Executable: ABYSS-P
16 total processes failed to start
/usr/bin/abyss-pe:503: recipe for target 'test-1.fa' failed
make: *** [test-1.fa] Error 134
Can you kindly help me to fix this error
Thanks in advance
Best regards

Adly Abd-Alla (Ph.D.)
Professor of Entomology
Molecular Biologist
Insect Pest Control Laboratory (IPCL)
FAO/IAEA Agriculture and Biotechnology Laboratory
International Atomic Energy Agency, Vienna Austria
Tel: +431260028425, Fax: +4312600447

--- End Message ---

Reply to: