[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with Abyss

Hi Tony,

On Thu, Feb 14, 2019 at 01:02:07PM +0000, Tony Travis wrote:
> It looks like "ABYSS-P" is missing from the "abyss" package:
> > root@beluga:~# apt policy abyss
> > abyss:
> >   Installed: 2.0.2-3
> >   Candidate: 2.0.2-3
> >   Version table:
> >  *** 2.0.2-3 500
> >         500 http://gb.archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages
> >         100 /var/lib/dpkg/status
> Using ABYSS-P with MPI is documented on Salsa:
> > https://salsa.debian.org/med-team/abyss#parallel-processing

I have no idea about the Ubuntu version but the stretch version is
2.0.2-2 which sounds pretty close.  My guess is that the build system
has some tweaks we missed to call to create ABYSS-P.  Since I'm
currently swamped with other stuff:  Would you mind filing a bug report

     reportbug abyss

with the information given by Adly Abdalla (in the best case with data
sets to reproduce either attached or as download link).  This will
ensure we will not forget this issue and can catch up later.  (BTW, I
have no idea how reportbug behaves when starting it from an Ubuntu
system.  Please make sure the mail created by reportbug is send to
control@bugs.debian.org which you can even do manually from your mail

I've found some

bin/Makefile.am:if !HAVE_LIBMPI
Makefile.am:if HAVE_LIBMPI

which will probably lead to a clue for a solution what we need to set
at build time ...
> Is this a similar Ubuntu problem to "metaphlan2", which is still not in
> Ubuntu-MATE 18.04 LTS?

Definitely not.  But I'm very sorry, I have no idea how packages are
propagating to Ubuntu and why this is missing. :-(
> AFAIK, Ubuntu 18.04 LTS is based on Debian "buster":
> > root@beluga:~# cat /etc/debian_version buster/sid
> Any ideas how to fix it?

Since these are totally different problems:  Please ask somewhere
on Ubuntu for the latter - I really have no idea.  The first one
should be fixable if we check the build system of abyss - if nothing
helps with the help if upstream.

Thanks as well to Adly Abdalla for the initial report.  We really
need to relay on user response since obviously nobody else did notice
this before.
Kind regards


> Date: Thu, 14 Feb 2019 11:41:14 +0000 (UTC)
> From: Adly Abdalla <adlyhhm@yahoo.com>
> To: "bug-make@gnu.org" <bug-make@gnu.org>
> Cc: Tony Travis <tony.travis@minke-informatics.co.uk>
> Subject: problem with Abyss
> Dear Sir/MsI recently installed Abyss assembler through the command 
> sudo apt-get install abysson Ubuntu Mate release 18.04.2 LTS (Bionic Beaver) 64-bit. However when I run Abyss-pe with the small sample data suggested in Githup bcgsc/abyss as default command "abyss-pe k=25 name=test in='test-data/reads1.fastq test-data/reads2.fastq'" it work fine but when I tried to use Parallel processing with 16 threads using the following command   "abyss-pe k=25 np=16 name=test in='test-data/reads1.fastq test-data/reads2.fastq" it failed and gave me this error 
> "adly@bioann:~$ abyss-pe k=25 np=16 name=test in='test-data/reads1.fastq test-data/reads2.fastq'/usr/bin/mpirun -np 16 ABYSS-P -k25 -q3    --coverage-hist=coverage.hist -s test-bubbles.fa  -o test-1.fa test-data/reads1.fastq test-data/reads2.fastq --------------------------------------------------------------------------mpirun was unable to find the specified executable file, and thereforedid not launch the job.  This error was first reported for processrank 0; it may have occurred for other processes as well.
> NOTE: A common cause for this error is misspelling a mpirun command      line parameter option (remember that mpirun interprets the first      unrecognized command line token as the executable).
> Node:       bioannExecutable: ABYSS-P--------------------------------------------------------------------------16 total processes failed to start/usr/bin/abyss-pe:503: recipe for target 'test-1.fa' failedmake: *** [test-1.fa] Error 134"Can you kindly help me to fix this errorThanks in advanceBest regardsAdly
> | 
> | 
> | 
> |  |  |
>  |
>  |
> | 
> |  | 
> bcgsc/abyss
> :microscope: Assemble large genomes using short reads - bcgsc/abyss
>  |
>  |
>  |
> Adly Abd-Alla (Ph.D.) 
>  Professor of Entomology
>  Molecular Biologist 
>  Insect Pest Control Laboratory (IPCL) 
>  FAO/IAEA Agriculture and Biotechnology Laboratory 
>  International Atomic Energy Agency, Vienna Austria 
>  Tel: +431260028425, Fax: +4312600447


Reply to: