[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: FastQC read for testing (Was: Some (minimal?) Java help needed)

Hi Carlos,

On Thu, Dec 06, 2012 at 04:16:32PM -0500, Carlos Borroto wrote:
> > Any volunteer to test the lintian clean package with some real data
> > before I upload?  Steffen?
> I'm interested in testing fastqc. This is my second time dealing with
> a debian package in svn and my second miserably fail.

That's sad.  BTW, I have no specific feeling whether to use Git or SVN.
So if confirm you would like to work on this package you prefer Git and
Steffen who has started the packaging does not insist moving it to Git
would be no problem at all.
> This is what I'm done so far:
> $ svn co svn://svn.debian.org/debian-med/trunk/ debian-med-trunk
> $ cd debian-med-trunk/packages/babraham/fastqc/trunk/
> $ ./debian/rules get-orig-source

May be you trapped into a pitfall I builded unintentionally here.  While
this does not explain your later problem please note that the
get-orig-source target in this specific form requires a not yet packaged
uscan.  The comments inside the debian/rules file will explain what to
do.  I worked a bit on a more clever uscan which is able to remove files
mentioned in debian/copyright Files-Excluded.  The discussion was done
on debian-devel list and the response was quite positive.  However, we
are currently in freeze time - so features like this need to wait a bit.

I perfectly agree that this trick is a bit hackish.  Ironically you
would not have run into this pitfall if we would have used Git with
pristine-tar.  So either you will use the uscan that is linked to in
the comment of debian/rules or I could upload the original tarball I
was using.  Unfortunately the new queue these days takes some time -
I uploaded at 20.11.2012 but it is not yet in unstable.  Otherwise you
could download the source from there as well.

> $ cd ../
> $ tar xvf tarballs/fastqc_0.10.1.orig.tar.gz
> $ cd FastQC/
> $ ln -s ../trunk/debian
> $ fakeroot ./debian/rules binary
> dh binary --with javahelper
>    dh_testdir
> <snip>
>    jh_manifest
> jh_manifest: No jar in fastqc matching usr/share/fastqc/fastqc.jar.
> make: *** [binary] Error 1

I guess I might need the full log (without the snip).  There might be
some slight chance that the build target is not createt in case the
original jar files remain present.  If you are reluctant to use the new
uscan you might simply remove all *.jar files from the original tarball
and create some fastqc_0.10.1+dfsg.orig.tar.gz  (or .xz as I decided to

> I also tried building with svn-buildpackage but that took me nowhere.

I admit I never seriosely used svn-buildpackage - so no advise from me
here, sorry.  My workflow is

   tar xaf <orig-tarball>
   cd <orig-source-dir>
   cp -a <path-to-svn>/debian .
   find . -name ".svn" -type d | xargs rm -rf

> I feel I'm missing something here. Could you please help me understand
> the workflow for building packages in svn?

In short:

   1. use uscan from
      to get the original tarball I used
   2. if this fails please send full build log (or make it accessible
   3. lets consider using Git if problems remain

Thanks for working on this



Reply to: