[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

More help for beast-mcmc needed (Was: Help with java package (beast-mcmc) needed)


On Wed, Jan 11, 2012 at 11:03:08AM +0100, Olivier Sallou wrote:
> Manifest file in JAR files is used only when program is called like:
> java -jar myfile.jar
> It uses in this case the manifest file and the default class.
> If a specific class is used:
> java -cp myfile.jar org.debian.myclass
> then classpath in manifest is not used, and all dependencies must be set
> in the java classpath (with -cp or -classpath, or env CLASSPATH).
> In this cas it must contains all jars needed by specific class call

After following these hints and adding CLASSPATH to those wrappers that
obviosely needed it I was able to fire up all those executables and
assumed that I now dealt with the issue.  However, it comes harder when
trying beast-mcmc on any of the included example.

I would be more than happy if anybody would download the packages from


and try for instance

 $ beast-mcmc /usr/share/doc/beast-mcmc/examples/calibrations/constrainedTaxaTest1.xm
Exception in thread "main" java.lang.NoClassDefFoundError: jebl/evolution/trees/RootedTree
        at dr.evomodelxml.tree.TreeMetricStatisticParser.<init>(Unknown Source)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
        at java.lang.Class.newInstance0(Class.java:372)
        at java.lang.Class.newInstance(Class.java:325)
        at dr.app.beast.BeastParser.loadProperties(Unknown Source)
        at dr.app.beast.BeastParser.<init>(Unknown Source)
        at dr.app.beast.BeastMain.<init>(Unknown Source)
        at dr.app.beast.BeastMain.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: jebl.evolution.trees.RootedTree
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
        ... 11 more

or any other example.  It always fails with the same error.  And yes, I
verified that /usr/share/java/jebl.jar contains the class in question
and I even tried the jebl.jar which is shipped with upstream tarball (it
ships with this lib included but an older version).  I also tried to
set CLASSPATH explicitely - no success with all trials.

This program is really a beast. :-(

Any help would be highly welcome.

Kind regards



Reply to: