[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#907042: opam 1.2.0 is deprecated (jessie)

On Sun, 2018-08-26 at 16:40 +0100, Nicolas Braud-Santoni wrote:
> Dear LTS contributors,
> I'm a co-maintainer of opam, the OCaml-specific dependencies manager, which
> is currently broken in olstable: the version in Jessie is 1.2.0 and does
> not support the current opam repository format[0], meaning that users
> cannot install new OPAM packages, get updates, ... (see #907042)
> I would like to propose an update in Jessie to 1.2.2, the same version as
> in Stretch, and Ben suggested that I ask here to check nobody would be
> opposed to it, and to get advise on the process to follow.
> Please note that upstream is planning a change to a new repository format
> (as part of releasing 2.0.0, which is currently in NEW) [1], but they plan
> to keep a branch of the repository in 1.2 format, and accept important
> updates there, so opam 1.2 will keep working for users of stable and LTS.

This seems OK in principle, but:

* Looking at the upstream CHANGES file, there seem to be quite large
non-bugfix changes between 1.2.0 and 1.2.2.  Are they definitely

* The Build-Depends for the version in stretch are not satisfiable in
jessie (specifically libdose3-ocaml-dev (>= 4.0.1-2~), libcmdliner-
ocaml-dev (>= 0.9.7~), ibjsonm-ocaml-dev).  It looks like you will need
to revert several of the packaging changes.

Ben Hutchings
Klipstein's 4th Law of Prototyping and Production:
                               A fail-safe circuit will destroy others.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: