[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#907042: opam 1.2.0 is deprecated (jessie)



Dear LTS contributors,

I'm a co-maintainer of opam, the OCaml-specific dependencies manager, which
is currently broken in olstable: the version in Jessie is 1.2.0 and does
not support the current opam repository format[0], meaning that users
cannot install new OPAM packages, get updates, ... (see #907042)

I would like to propose an update in Jessie to 1.2.2, the same version as
in Stretch, and Ben suggested that I ask here to check nobody would be
opposed to it, and to get advise on the process to follow.

Please note that upstream is planning a change to a new repository format
(as part of releasing 2.0.0, which is currently in NEW) [1], but they plan
to keep a branch of the repository in 1.2 format, and accept important
updates there, so opam 1.2 will keep working for users of stable and LTS.


Best,

  nicoo


[0]: https://opam.ocaml.org/blog/deprecating-opam-1-2-0/
[1]: http://opam.ocaml.org/blog/opam-2-0-0-repo-upgrade-roadmap/

Attachment: signature.asc
Description: PGP signature


Reply to: