[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Live built image not loading with installer

Used the sid kernel and built the image. But again when i tried to install it gives an error saying "kernel do not match. Live kernel is 3.2.0-3 and installer kernel is (*). Please reboot with correct kernel (*)."

On Jul 9, 2012 5:22 PM, "Ramu Sethu" <ramusethu@ymail.com> wrote:
Hi Ben

Adding config parameter "--debian-installer-gui true", will that help me for this kernel mismatch problem ??

On Mon, Jul 9, 2012 at 1:40 PM, Ramu Sethu <ramusethu@ymail.com> wrote:
Thanks for the suggestion...

Kernel mismatch problem, will this get solved if I use normal/regular installer along with live installer when building the image ??.
I went through manual, which says i have to preseed with "live-installer/enable=false" to have both installers.
If I do this, will I be able to install the wheezy through regular/normal installer? Or will i again face this issue even in this??

On Mon, Jul 9, 2012 at 3:40 AM, Ben Armstrong <synrg@sanctuary.nslug.ns.ca> wrote:
On 08/07/12 06:22 PM, Ramu Sethu wrote:
> Thanks all for the suggestion. Now it boots with sid version of live
> packages in config/packages.chroot. But when i try to install from the
> live image it says kernel version mismatch. It says the current live
> kernel is 3.2.0-2 and installer kernel is 3.2.0-3. Boot with correct kernel
> i use daily installer in the live build config.
> What is wrong ?? Do i need to mention 3.2.0-3 when building the live
> image ?? Or do i need to wait till wheezy updates itself to 3.2.0-3
> version???

Either wait until that kernel enters wheezy, or else also pull the sid
kernel into your config as well. Don't forget to include the related
kernel metapackages (grep your .packages list from your last build for
linux-image to find out which).


Reply to: