[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bogus samhain email alerts with rescue package list

On 2010-04-02 Daniel Baumann wrote:
> there might be people operating things in a chroot and 
> having samhain in there, so using debian_chroot is not generic enough. 
> therefore, i've added a hack in git for live-helper to avoid samhain 
> initializing its db through postinst.

I'm not sure it's related, but I just tried to build a KDE 4.4.2 rc0 which failed when trying to 
remove /var/state/samhain.

These are the last log items before the fail:

P: Deconfiguring file /etc/apt/apt.conf
P: Deconfiguring file /etc/hostname
P: Deconfiguring file /bin/hostname
P: Deconfiguring file /etc/resolv.conf
P: Deconfiguring file /etc/hosts
P: Deconfiguring file /usr/sbin/policy-rc.d
P: Deconfiguring file /usr/sbin/initctl
P: Deconfiguring file /sbin/start-stop-daemon
rmdir: failed to remove `/var/state/samhain': No such file or directory
P: Begin unmounting filesystems...

In order to build a KDE 4.4.2 rc0 image, I entered interactive mode since I needed the following 
command (amongst others):
#aptitude -t experimental-snapshots full-upgrade

KDE 4.4.x is not (yet) in the official debian archive, but available at http://qt-kde.debian.net/

I started creating the LiveCD with "./create-kde-livecd kde-standard". The script and the relevant 
config files are attached.

Related to building that KDE LiveCD, but not to the problem above, I have 2 questions:
- In order to install from both debian-multimedia and experimental-snapshots, I have the packages 
with the archive-keyring placed in config/chroot_local-packages, but I still get warning/errors about 
a GPG error about signatures which couldn't be validated. When I only used debian-multimedia I never 
got that problem. Did I do sth wrong or has the procedure with external repositories changed?
- Is it possible to specify the repository (experimental-snapshots in this case) with the package 
lists? Like what you do with "aptitude -t experimental-snapshots install x"


#firmware stuff
#if ARCHIVE_AREAS non-free
atmel-firmware bluez-firmware firmware-bnx2 firmware-bnx2x 
firmware-iwlwifi firmware-linux firmware-qlogic
firmware-ralink libertas-firmware linux-wlan-ng-firmware zd1211-firmware

#firmware-ipw2x00 this one doesn't work, interactive mode needed
#if ARCHIVE_AREAS contrib


#various system utilities
zip unzip bzip2 sshfs avahi-discover libnss-mdns wicd rdesktop

#if ARCHIVE_AREAS non-free
flashplugin-nonfree rar unrar
# kde-core - package list

## LH: KDE Core
#include <standard-x11>
#include <cknow-core>

#if DISTRIBUTION squeeze sid
kde-plasma-desktop polkit-kde-1 ark gwenview kate kcalc kmail akregator kaddressbook kdeplasma-addons kwalletmanager
korganizer kontact kopete kmix ksnapshot okular plasma-desktopthemes-artwork khelpcenter4 sweeper

MIRROR_BINARY="--mirror-binary http://ftp.nl.debian.org/debian/";
MIRROR_BINARY_SECURITY="--mirror-binary-security http://security.debian.org";
ARCHIVE_AREAS="main contrib non-free"
IMAGE_TYPE="-b iso-hybrid"
KERNEL_TYPE=" --linux-flavours 686"
APT_CONFIG=" --apt aptitude --apt-recommends disabled"
LH_OPTIONS="--interactive shell"


echo "Creating target folder"
echo "Setting configuration"
echo "Copying various config files"
cp $DEBIAN_LIVE_BASE_FOLDER/debian-multimedia-keyring_2008.10.16_all.deb $CONFIG_FOLDER/chroot_local-packages/
cp $DEBIAN_LIVE_BASE_FOLDER/pkg-kde-archive-keyring_2.1_all.deb $CONFIG_FOLDER/chroot_local-packages/
cp $DEBIAN_LIVE_BASE_FOLDER/chroot_sources/* $CONFIG_FOLDER/chroot_sources/
cp $DEBIAN_LIVE_BASE_FOLDER/local-package-lists/* $CONFIG_FOLDER/chroot_local-packageslists/

Reply to: