[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED - how to boot from a build in cardreader in acer one - device ist mmcblk0

Am Samstag, 2. Mai 2009 schrieb Carsten:
> Hi all,
> while trying set up a live system booting from a build in cardreader in an
> acer one 110 I run in the following problems:
> I put the kernel and initrd.img into the boot-partition on the harddisk
> (ssd) because the cardreader isn't bootable.
> But unfortunately the the initrd-scripts could't find the live image on the
> cardreader device.
> The cardreader device is correctly recognized by the kernel an the sdcard
> gets the devicenname mmcblk0. The first partition: mmcblk0p1.
> But in any way the cardreader doesnt't behave like another block device. I
> thought it could be because of the strange numbering of partitions like
> mmcblk0, mmcblk0p1 instead of mmcblk0, mmcblk01 - according to sda, sda1,
> ...
> After booting the initrd-scripts tries to find a live image in the /dev/sda
> partitions but after a while I get a shell from initrd. Via shell I can
> mount the parition e.g. mount -t ext2 /dev/mmcblk0p1 /mnt - for me the
> evidence that the block device is correctly recognized and works.
> So far I tried to identify the part in the initrd-scripts where the
> block-devices are inspected. But without result.
> Also I tried to make only one partition in the device so mmcblk0 is already
> the blockdevice where the image is in the subdir /live.
> Now the initrd script fails with the error:
>  panic No supported filesystem images found at /live.

It was so easy:

I simple put the device in the boot parameters of grub/syslinux:


There's nothing to change in the initrd.

If it also works with a partitioned sd-card where the device is mmcblk0p1 I 
didn't tried yet but it should.


Reply to: