[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't mount CIFS


On Fri, May 1, 2009 at 1:54 PM, Richard Nelson <unixabg@gmail.com> wrote:
>>> Do the logs on the windows server show any attempts to connect?
>> No trace of any attempt to connect. I think it may have to do with the
>> lack of /sbin/mount.cifs in the initrd.
>> Is live-helper normally supposed to put that in the initrd if I
>> specify cifs as the root filesystem, or do I have to add that to
>> LH_LINUX_PACKAGES or someting?
> I asked on irc for you and I am informed that:
> smbfs gets installed by lh_chroot_hacks if LH_BINARY_IMAGES=net
> Below is an exert from lh_chroot_hacks that confirms that information:
> case "${LH_BINARY_IMAGES}" in
>        net)
>                if [ ! -f chroot/usr/bin/smbmount ]
>                then
>                        Apt install smbfs
>                fi
> So it should be in there. Are you able to setup samba and test with it?

I set up a Samba server on a Linux machine and shared the bootimage/
from there. Again, I can browse through it with smbclient, but booting
through PXE using the share as the nfsroot yields the same result.
Most notably, the Samba server's log does not show any attempt to
connect during the PXE boot, while the connection through smbclient
was logged in great detail.

I noticed that smbfs gets installed in the chroot, but doesn't
mount.cifs still doesn't end up in the initrd image.
How is the system going to boot the root fs if it has (while still
running from the initrd) no way to access CIFS shares? I think this is
where my big disconnect is.

At this point, I would even go for NFS boot, but unfortunately, the
necessity to run the PXE server from a Vista machine is not negotiable
(i.e., not my choice at all) and nfsmount doesn't seem to play well
with Cygwin's NFS server.

Thank you,

Reply to: