[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lh_build on lenny and squashfs-tools

Philippe Lhardy wrote:

> 1) i put squashfs-tools_3.2r2-9_i386.deb in local packages
> config/chroot_local-packages/squashfs-tools_3.2r2-9_i386.deb
> 2) I believe this one should fix :
> creating config/chroot_local-includes/etc/apt/preferences :
> Package: squashfs-tools
> Pin: version 1:3.2r2-*
> Pin-Priority: 1001
> to maintain it even if an upgrade is coming.
> but i didn't manage to do a clean build since i have other problem with
> apt-proxy getting stuck.

Good Idea
Now there seems to be another way of getting lenny to work (havnt tried
the other one yet). But still this way can be good to have in the toolbox.

Your way works fine,the file (preferences) with pinning stops  the
upgrading to squashfs-tools1:3.3-3
And as You write one can get the old squasfs-tools from the apt-proxy cache.

BUT I had trouble, not with apt-proxy, instead I noticed that the file
in config/chroot_local-includes/etc/apt/preferences wasnt copied in
the chroot/etc/apt as it should.

The only way for me was to do it manually.
lh bootstrap
lh chroot
Then manually copy the file into chroot/etc/apt/preferences

lh binary
This way it works.

When I checked chroot_local-includes I cant find any error
the line with cpio that does the copy works when I do it manually. It
also says that it copies 1 block everytime its run. I run it with
set -x
And if I insert other files as for example a nonexisting directory and
files therein they get copied. Its only when there are a path as
/etc/apt/preferences I cant get it to work. Im out of ideas for the
moment, maybe someone else can test the same scenario and see if You get
the same result. Then I can file a bug. But I cant see for the moment
why it doesnt work.

Using Sid and live-helper 1.0~a37-2


Reply to: