[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#167747: MySQL-OpenSSL linking, news by MySQL team.about licensing

On Wed, Apr 02, 2003 at 06:03:18PM +0200, Andreas Metzler wrote:
> >> MySQL libraries currently are plain GPL, NOT LGPL as someone thought.
> > Unless they're trying to retroactively revoke the LGPL license, versions
> > of the libs prior to MySQL 4.0 are still available under thh LGPL.
> [...]
> It's not that simple.
> Quoting myself in http://bugs.debian.org/168554
> |Nevertheless this does not make libmysqlclient10 licensed under LGPL
> |because mysql-dfsg-3.23.53/libmysql/net.c includes mysqld_error.h, a
> |GPLed file.
> |
> |Please clarify this issue with upstream, whether this was an accident
> |and libmysqlclient10 is supposed to be LGPL or if it was intended and
> |libmysqlclient10 is indeed licensed under GPL.
>           cu andreas

Also, it's surely my fault, but I cannot find any LGPL proof of
statement in libmysql sources. Could anyone provide it?
Anyway I asked for clarifications about licensing on 3/4 series.

Francesco P. Lovergine

Reply to: