[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#167747: proftpd-mysql: links against OpenSSL and GPL licensed libmysqlclient10

On Wed, Nov 06, 2002 at 01:36:21AM +0000, Paul Martin wrote:
> On Mon, Nov 04, 2002 at 04:33:22PM +0100, Andreas Metzler wrote:
[Bugreport: proftpd-mysql linksed with GPLed libmysqlclient10 and OpenSSL]
>> If I find time I'll try to find somebody to write a nice letter (or
>> correct one I'd write) to the MYSQL developers with the appeal to
>> add an OpenSSL clause.

Update: It looks like Exim is soon going to support gnutls (the
development snapshot already does), so changing MySQL's license to
accommodate OpenSSL is of lower priority for me. This might be an
option for proftp, too.

>> PS: Feel free to change the bug's severity, I am not completely
>> sure about "serious".
> It's serious enough that if it's not resolved, we may have to pull
> proftpd-mysql, and possibly the -pgsql one too, as parts of libpgsql2
> are under a BSD-with-advertising licence.
Grrr. This sucks, and will probably need more bugreports:
grep-available -F Depends libpgsql2 | grep '^Package: ' | wc
     46      92    1055

I'd be surprised if not at least half of them were GPLed. I am ccing
        cu andreas

Reply to: