[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: ThinkPad T60p X11 driver problems

dekkzz78@gmail.com wrote:
> On 05/13, Bob Proulx wrote:
> > This following is on the problematic machine.
> > Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV530/M56 GL [Mobility FireGL V5200] bus-ID: 01:00.0
> >           Display Server: X.org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
> >           tty size: 232x75 Advanced Data: N/A for root
> Try running it as user not root then just comparing the 2 output gfx
> details.

I thought I remember it complaining that it needed root when I ran it
as non-root.  Because that prevented it full access to the machine
checks that it needed.  No?  I will try it again.  In the meantime
following parallel paths I think the problem was the missing
firmware.  You will see this in my next message.

> You did the install?


For a little more background that might or might not be interesting is
that my 80 year old retired airplane mechanic's wife is the computer
user in their family and has been using a MS-Windows machine.  It had
become very slow and difficult to maintain.  So I gave them this T60p
laptop running, I am embarrassed to say here, Ubuntu 16.04.  The
hardware may sound old but it was basically a brand new and never
before used laptop despite the vintage with a large bright display.
It had the best sized display for them to see and that is important.

There were various reasons for using Ubuntu on that system instead of
my preference of Debian.  However on the big plus side she loved the
system running a kiosk mode configuration with the cinamon desktop
with the largest fonts and icons I could configure.  The only program
they ever run is a web browser.  It was a good upgrade for them and
they really liked it.

That worked great for about two years until just recently when two
things happened.  One is that something happened to the graphics
driver and it had this very odd flashing black rectangle problem
whenever the display was being updated.  Extremely visible and
annoying.  Two is that Ubuntu dropped all support for 32-bit hardware
as of Ubuntu 18.04.  There was no upgrade future.  Of course I know
16.04 is supported a while longer.

In any case I wanted to switch the system back to my preference of
Debian and after backing everything up I installed Stretch 9 as a
fresh installation.  And that is when I ran into these graphics driver
problems.  (And an upgrade to Sid did not fix things.)  But thanks to
the help here I think I have the solution.  More in a future message.

> > [     5.146] Current Operating System: Linux teaclub 4.9.0-6-686-pae #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) i686
> That date stamp looks like it's worth checking if you have the most
> upto date Stretch 32-bit kernel, a new 64-bit one came out last week
> due to spectre et al.

That kernel should have been the latest available kernel at the time
of the installation.  However unexpected confusion can result when
switching back and forth between machines and multiple installations
and so forth.

I think I am on track now.  I am re-installing a pristine Stretch 9 to
test the theory.


Attachment: signature.asc
Description: PGP signature

Reply to: