[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

USB audio device (webcam) for thinkpad 410


First of all: I can listen to music in all the players, by internal speakers or by headset headphones.

I bought a Creative Live HD VF 0790 usb webcam, which is advertised to work with Linux, and plugged it into a Thinkpad 410s.

According to dmesg, it is recognized by name and the kernel (v. 4.0.5) seems to use the uvc driver.

According to lspci, there are HDA Intel 5 Series / 3400 audio chipset and a 'Mic' and 'Dock Mic' device on PCI.

I can also see a CX20585 'hdaudioC1D0' type 'speaker', which appears as audio device in the players. It appears as both output and mic device in audacity.

Somewhere i read i should make sure /dev/audio* gets created after i plug in the webcam. I can see a /dev/video0 appearing, but there is no /dev/audio*.

I can see the Live cam named correctly as a capture device in xfce4-mixer (using ALSA) , it is the only channel shown for this device, and i turned it to maximal. For the the HDA Intel device, i turned all capture / mic channels either off or to 100 or 50%, it does not make any difference with regard to the tested applications. 

After starting guvcview, i have the video working but there seems to be no audio input (capture). Although i don't even know exactly how to test this. Just 'captured' video sequences and played them in vlc - always no audio.

In guvcview, i can switch audio to the Live cam audio device. Then, the visible meter shows maximal (100%, red) input w/o me doing anything, and it does not respond to noise or voice. Still, saving a test stream, the result has no audio. Later on, after some reboot, it does not even show the noise thing, just dead silence.

The guvcview, audio controls button lets me choose the API:   No sound, portaudio, or pulseaudio. 
I did not install pulseaudio and would prefer to avoid it. Can't i use a webcam w/o pulseaudio ? Do i need jackd fpr 'portaudio' ? I installed jackd (version 2) and started it with qjackctl but it does not seem to make a difference.

I tested some other other applications. In audacity, there is the 'Click to start monitoring' thing on the microphone meter. With internal mic, it works as expected, i can record my voice. With Live cam device (which is shown correctly and i can chose it as capture device) there are exactly 2 signals, depending on the XFCE4 alsamixer adjustment: With capture channel off, there is zero signal, with anything else, it's 100% (red) and just loud noise. As mentioned above, after some testing and reboot, all zero, not even the noise remained. I had to stop the testing at this point because i'm running out of time.
vlc does also not 'capture' audio, when it records a webcam sequence (the video is working but no sound).

Does 'cheese' indicate audio at all ? 

As a means of avoiding the problem in the first place, i plugged my headset into the laptop audio port (the small plug thing at the left side which has a headset symbol) and tried all these applications again. But i can't get any audio input, if anything then the internal / inbuilt mic is used. (It's easy to test, if you go away the audio signal faints accordingly)- I simply don't know how to say 'use the headset audio port'. 
With my old Thinkpad T61 the headset worked out of the box once plugged in. (No more here, can't compare anymore) 
In all the mentioned applications, i can't see any choice offered like 'internal mic' or 'headset mic'. 

xfce-mixer has some IEC9something audio switches disabled, which i don't know about, but they made no difference.

To summarize, i have two problems:

1) The onboard mic is very low quality and i really want to get either the headset or the webcam microphone working. 

2) I do not know how to check, in a video chat application, the webcam audio input. Normally it would not send my own talk to the laptop output device, no ? Do i need to actually talk to someone ? But i would prefer to install skype only after i having the hardware running, in case this comes with its own trouble. But if you think i should debug this with skype, i'd give this a try.

Any help would be greatly appreciated.

Reply to: