[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing debian-testing-amd64-netinst.iso on a partition of a Macbook 5,2

On Sat, Jan 25, 2014 at 6:54 AM, Daniel Landau <daniel.landau@iki.fi> wrote:
On 21.01.2014 04:34, Alexandros Drymonitis wrote:
> Hi,
> New to this list and Debian (and rather new to Linux as well). I'm on a
> Macbook 5,2 with a partitioned hard drive with OS X and (now) free
> space. I used to have Ubuntu 12.04 installed but I want to switch to
> Debian. I tried to install Debian wheezy 7.2 from a liveCD but the
> graphical installed couldn't install Grub on any partition of the hard
> drive, not even the MBR.

Usually graphical installers cater for the common case or the most
common exceptions. Even though the computers from Apple are quite
popular nowadays they are by no means the easiest of environments to get
a GNU/Linux system set up. If the graphical installer doesn't cover your
use case you might have to opt for command line tools.
I hope this is not really necessary as my command line capabilities are really limited and I'm not sure I'll be able to instal it from there..

That said, I myself have a Macbook 5,1 with rEFInd (a fork of rEFIt) a
hybrid GPT/MBR partition table and GRUB 2 installed to the partition
with the GNU/Linux system. The particular system I have now is not
Debian but I had that too previously.

> From the Pure Data list I was 'advised' to try Debian-testing from here
> <http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/amd64/iso-cd/>,
> but during installation I was asked to specify a place for EFI. I have
> installed rEFIt <http://refit.sourceforge.net/> on my laptop as I
> followed this
> <http://www.lifehacker.com.au/2012/08/how-to-dual-boot-linux-on-your-mac/>
> tutorial on dual booting a Mac with Linux, so I thought that the
> partition where rEFIt lies should be the one to install EFI, but I'm
> really not sure if this is the right thing to do, so thought of asking here.
> Another thing is that even though in the Disk Utility app I've deleted
> all partitions except from the Macintosh and the Recovery HD, the
> graphical installer of Debian sees the following partitions:
> sda1: EFI
> sda2: Macintosh
> sda3: Recovery HD
> sda4: some ext4 I think
> sda5: free space for Debian
> sda6: swap area

What's on sda4? It shouldn't be anything Mac OS X is using at least. Is
that leftovers from the previous Ubuntu install? You mentioned that you
have a MBR which would imply that you ran the tool included with rEFIt
to create a hybrid GPT/MBR partition table. The MBR is limited to four
primary partitions, so that is one possible reason why you couldn't
install GRUB in sda5, if you tried that.
It looks strange to me cause I have used the Disk Utility app to erase any partition that doesn't really have something, so the app now shows only the Macintosh HD and the Recovery HD (in the Debian installation these are sda2 and sda3)

My main questions for now are the following:
During installation I get to the 'Host name for this system'. There's a 'debian' written there by default and that's what I'm using, is that OK?
Immediately afterwards I have to set the domain name, which I set to .org. I really have no idea what should go there, so I put .org since Debian's website is .org.
Then I get to the partitions which are the following:
>             3.1KB          FREE SPACE
>   #1  204.7MB  B     fat32                  EFI System P
>   #2  349.2GB          hfs+                   Macintosh HD
>   #3  650.0MB          hfs+                   Recovery HD
>         352.3KB          FREE SPACE
>   #5  142.0GB      f   ext4                                               /
>   #6      4.0GB      f   swap                                             swap
>   #4      4.0GB  B      swap                   Linux swap
>             1.1MB          FREE SPACE

If I choose to finish with the disk partitions the next page says 'No EFI partition was found' and asks me whether I want to go back. My guess is that I should choose partition #1 for EFI since it already says 'EFI System P', but then I don't really know. Some partitions must be there from previous attempts to install Debian or some other Linux distribution (Ubuntu Studio or Sabayon). For example partition #4, I remember naming it Linux swap, but in some later attempt I set #6 as the swap area. Have I made a mess there?

> Since sda1 is EFI, I guess that's where I should install it, but thought
> of asking before I give it a try, since I don't know that much about
> computers and I don't want to mess up my laptop completely.

From what I've read, you should be able to boot a GNU/Linux system with
EFI, but I don't have any personal experience with that, so I can't
really help you with that.

Overall, if you have some specific error messages you got, sharing those
would be most helpfull. Also could you reiterate step by step what you
tried, and at which points something different from what you expected
happened (again including the error messages).
I wrote down everything till the point I kind of get stuck, hope that helps. Thanks.

Daniel Landau

Reply to: