[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fglrx: Out of memory when allocating device heads

It still does not really work.  The 'radeonhd' driver appears to have no GL direct rendering. Google earth, for example, barfs that it will be using a slow emulation.

When i used the 'radeon' driver it would not enable the maximal resolution (1400x1050@16) so i stick with 'radeonhd'. Interestingly this one does not depend on the firmware-linux package, and i deinstalled it.

Meanwhile i tried compiling fglrx with Debian kernel 2.6.30-2, in a recent Sid, but it's still the same ("Cannot allocate memory").

According to
ATI has dropped support for most of the X series Radeon cards.

"AMD has moved a number of DX9 ATI Radeon™ graphics accelerators products to a legacy driver support structure.  This change impacts Windows XP, Windows Vista, and Linux distributions. 
(...) No new features will be provided in future driver updates.  The Linux ATI Catalyst™ driver will only be supported in Linux distributions prior to February 2009 for the legacy products listed above."

However why does that necessarily imply that the latest fglrx packages do not work anymore.
I have 2 questions:

(1) 'modprobe fglrx' results in the 'Cannot allocate memory' failure, it seems to be a kernel related problem. Would it be possible to fix that on the kernel side ?

(2) The previous fglrx versions worked in the past, is it possible to prepare a working package for Sid ? 

I tried to downgrade Xorg and any fglrx packages to 'stable' but then fglrx-source would no more build. It also seemed that reinstalling fglrx messed up radeonhd somehow, and i had to purge all fglrx-* packages to get it clean again.

Reply to: