[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wmaster0: unknown hardware address type 801 while getting IP address for eth0 interface using DHCP

Am Mittwoch, 16. September 2009 12:12:28 schrieb Alexander Kaphuk:
> Hi,
> I'm still having trouble configuring my wired network interface on
> Debian Lenny running on HP Compaq Presario CQ61.
> I put "auto eth0; iface eth0 inet dhcp" (each statment on separate line
> as shown in debian wiki) into my /etc/network/interfaces file.
> I ran "ifdown eth0; ifup eth0". I got this error message in the output
> "wmaster0: unknown hardware address type 801".
> I also tried configuring the network setting manually, but to no avail.
> (see output of ifconfig -a and lspci -k below for details).
> Is it something I'm doing wrong? Why wouldn't DHCP work during the
> installation process?

yes, sorry, I think you're doing wrong.
The wmaster0 is a fake of the wifi-driver needed by the developers in 
developing the driver, nothing you could or should configure.
> I have done quite a bit of googling about it. I have seen posts of other
> people experiencing similar problems as me, but so far have found no
> solution to the problem.
> I'd appreciate any feedback on what needs to be done in my situation.

Try out to find the intel developers-manual (iwlwifi)(don't care about 
atheros). Might be on http://intellinuxwireless.org. There it should be 
For me it was'nt that easy to fix the problem. Because of this I'actually 
don't really remember the way I went to finally find the solution.
 And tonight, I'm sorry, I don't have the time to help you. May be in the next 
few days. Let me know, if you succeed and if, how, and even otherwise.
> Thanking you all in advance.
> Alexander Kapshuk.

Michael-E. Voges

Reply to: