[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wireless on an old Thinkpad 600

On Fri, 31 Oct 2008 00:47:19 +0100
Bernard <bdebreil@teaser.fr> wrote:

> Hi Clayton, Hi to everyone,
> Le Wed, 29 Oct 2008 07:40:07 +0100, Clayton a écrit :
> router "fonera". I got something new though. At first, I must point
> out that I have installed ETCH instead of the Sarge that I had. The
> problems that I had encountered with X environment have been mostly
> solved to a point that I now get a workable environment. On that ETCH
> system, when the router FONERA is cabled to the pcmcia D-Link
> Ethernet card, 'ifconfig' gives me this :
> #ifconfig
> eth0	Encap link:Ethernet HWaddr 00:80:.....
> 	..............
> 	etc..
> eth0:3	Encap link: Ethernet HWadr 00:80:..... (same address as
> above) inet adr: Broadcast:
> 	Interruption: 3 Base address:0x300
> lo	Encap link: Local loop
> 	inet adr:
> 	.........
> 	etc..
> eth0:3 ??  What on Earth is this ?   I have never seen anything like
> this... this eth0:3 only appears after a few 2-3 minutes. The IP
> address that it bears ( is of the same domain as that of
> the given address of the 'FONERA' (

I am far from an expert on networking, but your "eth0:3" looks like a
virtual interface: http://handsonhowto.com/virt.html

This should not appear spontaneously, perhaps grep /etc for "eth0:3"
and see what might be causing this? Maybe try
deleting  /etc/udev/rules.d/70-persistent-net.rules and reboot? (I am
grasping at straws, but I am recalling having a major headache
with that persistent-net.rules during a past upgrade.....)

> If the ifconfig test is being done
> right after boot, eth0:3 does not show. Furthermore, after another
> while (or after the call of another function, I can't remember for
> sure), iwconfig mentions, besides 'lo', 'eth0' and 'irda0', something
> else that is called 'sit0'.
> I have not so far been able to 'enter' this router using
> Firefox/Iceweasel by any of the addresses that worked under Microsoft
> Windows :, and, since I switched it into "client" mode :
> So far, I really don't know what I should try next, and how am I
> going to use this router in client mode as a medium to get Wireless
> connexion to my DSL router and, from there, to the Internet.

I think you need to figure out where it is coming from / get rid of that
eth0:3 thing before worrying about networking. This is totally
non-standard behavior, and I too have never seen that happen before....

> > I don't know anything about Fonera's, but most routers
> by default run
> > DHCP networks, so you *probably* need to to configure your ethernet
> > interface for DHCP, ie. if your card is eth0, make sure
> > /etc/network/interfaces contains this line:
> > 
> > iface eth0 inet dhcp
> > 
> > then as root in a terminal, execute these two commands:
> > 
> > ifdown eth0
> > ifup eth0
> > 
> > If it works, you will see an IP address assigned in your terminal.
> Yes, this works all right with my DSL box/router whenever the
> appropriate cable is there, as my /etc/network/interfaces file does
> contain 'iface eth0 inet dhcp', but I don't know how to get my other
> router 'FONERA' to work and wirelessly connect to said DSL/router.
> When the cable links the Fonera instead of the DSL box/router, the
> 'ifup eth0' command shows repeated attempts :
> DHCPDISCOVER on eth0 to port 67 interval 7
> DHCPDISCOVER on eth0 to port 67 interval 9
> DHCPDISCOVER on eth0 to port 67 interval 21
> DHCPDISCOVER on eth0 to port 67 interval 18
> ....
> No DHCPOFFERS received
> No working leases in persistent database - sleeping

ifconfig lists all active ("up") network interfaces.
"ifconfig -a" lists all installed network interfaces, whether they are
active or not.

The one you want to use (eth0, eth1, eth2, ...., wlan0, maybe even
eth0:3) should be represented in the /etc/network/interfaces file per
above. As long as you are doing ifup on the right one, it should work
if there is nothing wrong with your router (unlikely since Windows
works?) or there is something more subtle wrong on your end. Try ifup
on eth0:3. Try to get rid of eth0:3 because it is muddying the water.


Reply to: