[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wireless on an old Thinkpad 600

Hi Clayton, Hi to everyone,

Le Wed, 29 Oct 2008 07:40:07 +0100, Clayton a écrit :

> Hi Bernard,

>> My first question concerns the cable connexion between the router
>> Fonera and my pcmcia Ethernet cards. My first Ethernet card, the IBM
> Do not worry (much) about the cable that comes with a particular
> Ethernet card. If the plug fits in the socket, and you can make the
> card work in any environment using any OS, you know the card and the
> cable are good. Then if you trouble in a different environment, the
> problem probably lies with either the network configuration of your OS
> or the router you are trying to connect to.
> If you successfully connected to the Fonera with this same card using a
> Windows system, then there is no problem with card or Fonera.
> Networking is not properly configured on your Debian system.
>> this problem ?  which Ethernet pcmcia card will have the same
>> plugging system as the EtherJet card as well as being workable under
>> Linux ?  From the above report of trials, I am unable to know whether
>> the fact that I cannot run this system under Linux is due to this
>> system or to the connection mode...
> Again, do not worry about what the cable looks like, as long as you know
> the cable works. I think this is the chapter of the manual that you are
> looking for:
> http://www.debian.org/doc/manuals/reference/ch-gateway.en.html#s-net-high

This is an interresting document for me. I read it and bookmarked it,
since I am sure that I will soon get back to it. Still, at this stage, I
can't figure how I am going to get on the way with this router
"fonera". I got something new though. At first, I must point out that I
have installed ETCH instead of the Sarge that I had. The problems that I
had encountered with X environment have been mostly solved to a point that
I now get a workable environment. On that ETCH system, when the router
FONERA is cabled to the pcmcia D-Link Ethernet card, 'ifconfig' gives me
this :

eth0	Encap link:Ethernet HWaddr 00:80:.....

eth0:3	Encap link: Ethernet HWadr 00:80:..... (same address as above)
	inet adr: Broadcast: netmask:
	Interruption: 3 Base address:0x300

lo	Encap link: Local loop
	inet adr:

eth0:3 ??  What on Earth is this ?   I have never seen anything like
this... this eth0:3 only appears after a few 2-3 minutes. The IP address
that it bears ( is of the same domain as that of the given
address of the 'FONERA' (

If the ifconfig test is being done
right after boot, eth0:3 does not show. Furthermore, after another while
(or after the call of another function, I can't remember for sure),
iwconfig mentions, besides 'lo', 'eth0' and 'irda0', something else that
is called 'sit0'.

I have not so far been able to 'enter' this router using Firefox/Iceweasel
by any of the addresses that worked under Microsoft Windows :, and, since I switched it into "client" mode :

So far, I really don't know what I should try next, and how am I going to
use this router in client mode as a medium to get Wireless connexion to
my DSL router and, from there, to the Internet.

Thanks in advance for more hints.

> I don't know anything about Fonera's, but most routers
by default run
> DHCP networks, so you *probably* need to to configure your ethernet
> interface for DHCP, ie. if your card is eth0, make sure
> /etc/network/interfaces contains this line:
> iface eth0 inet dhcp
> then as root in a terminal, execute these two commands:
> ifdown eth0
> ifup eth0
> If it works, you will see an IP address assigned in your terminal.

Yes, this works all right with my DSL box/router whenever the appropriate
cable is there, as my /etc/network/interfaces file does contain 'iface
eth0 inet dhcp', but I don't know how to get my other router 'FONERA' to
work and wirelessly connect to said DSL/router.

When the cable links the Fonera instead of the DSL box/router, the 'ifup
eth0' command shows repeated attempts :

DHCPDISCOVER on eth0 to port 67 interval 7
DHCPDISCOVER on eth0 to port 67 interval 9
DHCPDISCOVER on eth0 to port 67 interval 21
DHCPDISCOVER on eth0 to port 67 interval 18
No DHCPOFFERS received
No working leases in persistent database - sleeping

Reply to: