[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Nothing on display after suspend/resume

rangalo wrote:
powersave -u  # -u is for suspend to ram (suspend to disk doesn't work
at all, it just hangs while suspending)

command, but while resuming, I get only a black screen, I see a lot of
activity of my hard-disk and I can hear the fans running, so I think
that resume is working, but there is something with the display.

I had that same problem with my Dell Inspiron 8600. I tried the "hibernate" package, which someone suggested, and everything works fine, now. I recall there were a couple of changes to the config that I was told to make, but I think hibernate fixed the problem even without those changes.

Try "hibernate" first. If that doesn't work, then I can go find the changes I made.

One thing you probably do have to do is change one config file in /etc/hibernate. There's a config file which basically lists the types of hibernation to try and in what order. It's something like:
  Load /etc/hibernate/ram.conf
  Load /etc/hibernate/sysfs-ram.conf
  Load /etc/hibernate/ususpend-ram.conf
  Load /etc/hibernate/disk.conf
  Load /etc/hibernate/sysfs-disk.conf
  Load /etc/hibernate/ususpend-disk.conf

Or something like that. You can rearrange them to alter what order they're tried in. You can probably also just use the "hibernate-disk" and "hibernate-ram" commands.

- Joe

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply to: