[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Nothing on display after suspend/resume

On 6/26/07, Joe Emenaker <joe@emenaker.com> wrote:
rangalo wrote:
> powersave -u  # -u is for suspend to ram (suspend to disk doesn't work
> at all, it just hangs while suspending)
> command, but while resuming, I get only a black screen, I see a lot of
> activity of my hard-disk and I can hear the fans running, so I think
> that resume is working, but there is something with the display.

I had that same problem with my Dell Inspiron 8600. I tried the
"hibernate" package, which someone suggested, and everything works fine,
now. I recall there were a couple of changes to the config that I was
told to make, but I think hibernate fixed the problem even without those

Try "hibernate" first. If that doesn't work, then I can go find the
changes I made.

One thing you probably do have to do is change one config file in
/etc/hibernate. There's a config file which basically lists the types of
hibernation to try and in what order. It's something like:
   Load /etc/hibernate/ram.conf
   Load /etc/hibernate/sysfs-ram.conf
   Load /etc/hibernate/ususpend-ram.conf
   Load /etc/hibernate/disk.conf
   Load /etc/hibernate/sysfs-disk.conf
   Load /etc/hibernate/ususpend-disk.conf

Or something like that. You can rearrange them to alter what order
they're tried in. You can probably also just use the "hibernate-disk"
and "hibernate-ram" commands.

- Joe

Hi all,

Thanks for your replies.

Bhaskar: I cannot switch to the terminal with Alt+F1 or any other virtual terminal for that.

Kevin: I used the raw (low-level) program s2disk and s2ram for it but they do the same thing as the powersave script, which additionally removes some kernel modules.

Joe: I installed hibernate, but with the same result. May be you can suggest me the configs you made for making it work for you.


Reply to: