[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wireless network adapter: ndiswrapper loaded, but cannot connect to network

I have a Toshiba Satellite 2850 laptop running Debian kernel
2.6.18-4-686 with a Linksys wireless network card (pcmcia), model
WPC54G  802.11g.

I followed the ndiswrapper installation instructions from this site --
http://ch.tudelft.nl/~arthur/wpc54g/ -- and everything succeeded.

That is, until I got to the final step, scanning for access points:

# iwlist eth1 scan
eth1      Interface doesn't support scanning : No such device

According to iwconfig, the card is there (i.e., the modprobe of
ndiswrapper worked), but not attached to any network:

# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:""  Nickname:"Broadcom 4306"
         Mode:Managed  Frequency=2.437 GHz  Access Point: Invalid
         RTS thr:off   Fragment thr:off
         Encryption key:off
         Link Quality:0  Signal level:0  Noise level:0
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

I also tried connecting using the network gnome gui (Desktop ->
Administration -> Networking), and got the same result.

I.e., just like iwconfig, the gui detects the wireless network
adaptor, but clicking the "Activate" button doesn't work.

Any suggestions?

Reply to: