[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Running DHCP once wpa_supplicant associates with an AP?



Es Dimarts, 1 de Novembre de 2005 22:21, en Luca Pireddu va escriure:
| On Tuesday 01 November 2005 11:36, Joan Tur wrote:
| > Es Dimarts, 1 de Novembre de 2005 02:40, en Joe Emenaker va escriure:
| > | All I want to do is have wpa_supplicant trigger a dhclient (or other
| > | dhcp client) for an interface when it associates with an AP.
| >
| > I'm using waproamd to manage that, mainly because my dsl router can only
| > manage 128b wep keys, but maybe that's not your case.
| >
| > Anyway I'd like to make you, wpa_supplicant users, a question.  Since
| > kernel 2.6.13 waproamd does no longer work, so I stay with 2.6.12...
| >
| > Is any of you using wep only?  If so, what's your config file?
| >
| > TIA  ;)
| >
| > PD I'm using a static 128b wep key, dhcp, eth1=noauto in interfaces,
| > ipw2200 1.0.6 (1.0.8 doesn't work with kernel 2.6.12).
|
| I only use WEP.  Here is my wpa_supplicant.conf
|
| ctrl_interface=/var/run/wpa_supplicant
| ctrl_interface_group=0
| eapol_version=1
| ap_scan=1
| fast_reauth=1
|
| network={
|   ssid="a wep network essid"
|   key_mgmt=NONE
|   wep_key0=1111111111
|   wep_tx_keyidx=0
|   auth_alg=SHARED
| }
|
| network={
|   ssid="unencrypted"
|   key_mgmt=NONE
| }
|
| network={
|   ssid="any"
|   key_mgmt=NONE
| }
|
| Notice that my encrypted network uses shared keys.  You'll have to make
| sure your AP's configuration matches (either "shared" or "open").
Thanks for your help.  I've tryed your configuration, but it didn't work for 
me, so I've began testing, and...

I've got it working with ap_scan=2, only with:
-kernel 2.6.12, ipw2200 1.0.6, ieee80211 1.0.3, firmware 2.3.

No way of:
-kernel 2.6.14, ipw2200 1.0.6, ieee80211 1.0.3, firmware 2.3; ieee80211 
doesn't compile.
-kernel 2.6.14, ipw2200 1.0.8, ieee80211 1.1.6, firmware 2.4; it compiles & 
loads fine, but does not associate  8-?

For now it's ok, I've got the waproamd replacement working.  I'll try to guess 
what's wrong with the above 2 configurations if I have to.

Thanks again  ;)

| Luca

-- 
Joan Tur (aka Quini), Eivissa-Spain
    Jabber: quini2k@jabber.org
       Yahoo & AIM: quini2k
        www.ClubIbosim.org
  Linux: usuari registrat 190.783

Attachment: pgpWIBHfJVMwg.pgp
Description: PGP signature


Reply to: