[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re:Cisco 350 with WEP - SOLVED


(Apologies, but my mail clients won't let me set the In-Reply-To header, so I'm resorting to the above, and cc'ing the OP.  And I'm not on this list, so please CC me with any replies.)
I was having extraordinary difficulty getting my Cisco Aironet 350 to connect to my WEP-encrypted wireless network.  I Googled, and found, among other things, this thread - but no solution.  I have finally succeeded, and am so connected even as I speak.

I've described the process at http://ul451.gsu.edu/~pwiseman/airo350.html, but here's a condensed version:

Set your access point to use a "Shared Key".

Then write a shell script to connect to your wireless network, along the following lines:

/sbin/iwconfig eth0 essid "YourNetworkID"
echo 0 XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX: > /proc/driver/aironet/eth0/WepKey
iwconfig eth0 key restricted [1]
/sbin/ifup eth0

For the life of me, I could not get iwconfig to set the key, but that echo command does it.  The script needs to be run as 'root' as mere mortals can't set parameters with iwconfig (or so it seems by me, anyway).  I haven't tried setting the script SUID root, but presumably that would work.

HTH someone

Reply to: