[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: netenv on sid

On Fri, 13 May 2005 22:00:20 +0200, plungeknob scareaunts wrote:
> Hi everyone,
> I use DHCP to access the Internet at home, running Sid on my Toshiba.
> Yesterday I downloaded netenv. Having little background knowledge on
> networking and even less on modifying configuration files on Debian, I
> was hoping to use my Debian in the office, which has a cable Lan
> connection with a fixed  IP address The network is
> Windows based.
> So  this is  what I enterned when the Netenv dialog box came up   during bootup:
> current IP-address:  
> netmask of the current subnet: 
> IP-address  of the current network:
> Broadcast-address:
> Gateway address: 
> IP-address of the current nameserver:
> Everything, except for the network IP and the broadcast address , is
> exactly what I'd enter when I'm on Windows. But I can't seem to get
> connected to  the Internet with the above on Debian. Or I was probably
> connected already, only the browser kept telling me "servers not
> found".
> Did I do something wrong? Do I need Samba or something like that?
> Thanks!
> Han


Have you tried it manually at first?  Like try running all the linux
commands to give yourself an IP address, the netmask, route etc?  I know
this sounds more difficult but you can see how things go and see command
line output.  I would do these commands as root or close to it:

ifconfig eth0 netmask
route add default gw

now edit your /etc/resolv.conf and put in:


now try pinging something like www.yahoo.com or similar.

no rebooting necessary... So did things work?  If not, may want to ensure
that the kernel is agreeing with the network card you are using and that
it gets inserted into the running kernel.  I don't know much about
netenv all in all, so I cannot comment on its usefulness.  I tend to
create different schemes in my /etc/network/interfaces for a variety of
places that I need network access like wired and wireless.  Then I just
do an "ifup eth1=work" or whatever and that wireless scheme comes up with
either static or dhcp assignments.  I have done both this way with wired
and wireless.  Works great for me.

I would definitely try the command line approach first and see if things
work and look for any problems.  You may need to change eth0 above or
not...  It will definitely work better when you are at the place for the
network settings :)

Michael Perry | do or do not. There is no try. -Master Yoda
mperry@lnxpowered.org | http://www.lnxpowered.org

Reply to: