[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with linux-kernel for ibm-thinkpad t40?

Hello folks,

I've now got sound also with also. Very happy :)

I'm the one who didn't have /dev/dsp. So I recompiled the kernel with Javier-Elias's config and /dev/dsp appeared. Kudos Javier! Good thing (only now my USB mouse doesn't work, but that's a different story)

Still got 2 issues though:

When I boot my laptop, esd seems to use /dev/dsp - the music player can't play because of this. The sound server reports something like it: "The sound device is busy.." So when I *fuser /dev/dsp* and kill the PID - it plays! But I have to do this everytime I boot. Is there a way to get rid of this problem?

My gnome-alsamixer settings keep changing back to default when I boot/reboot, so I also have to reset these everytime. Anyone?

Thanks till so far for the solutions brought up though :)
Christian C.

Javier-Elias Vasquez-Vivas wrote:

This was the issue...  Thanks a lot for all the help and to all that helped...



On 5/9/05, Peter Frühberger <peter.fruehberger@gmail.com> wrote:
Hash: SHA1

Andre Timmermann wrote:
Hello list,

Am Freitag, den 06.05.2005, 22:25 -0600 schrieb Javier-Elias


I have installed on a IBM-T40 debian unstable.  I had my own compiled
linux-2.6.10 working well for quite a while, but I needed to recompile
the kernel, so I decided to go for linux-  As usual its
compilation was not a problem, and reboot is smooth...  Problems is
that when openning xmms and trying to listen anything with sound card,
nothing shows up, just silence...
nearly the same here. I am running debian unstable on an IBM R50P. I
decided to use and there was silence.

A few days later I tried and everything was OK again.

I was not able to track down the error. The system "thinks" to play the
sound (according to the analyzer in xmms) so it seemes to be a problem
with the mixer.

Some digging in the dark:
Perhaps it has something to do with the kernel-version and the
alsa-version in unstable - did you try an upgrate?

Another guess is kernel-version versus gcc-version - again: try upgrade
and then rebuild the kernel.


Have you looked here:

they propose following solution:

.. you just need to mute the two jack sense mixers switches...
PS, I closed the bug as it was solved (and anyway not Debian-related)....

- --
                   Key-ID:     0x1A995A9B
                   keyserver: pgp.mit.edu
Fingerprint: 4606 DA19 EC2E 9A0B 0157  C81B DA07 CF63 1A99 5A9B
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Reply to: