[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pentium-Classic Laptop/PCMCIA-Ethernet-Card


On Thursday 09 December 2004 16:31, Michael Jarosch wrote:
> Innovace HB600PX-Laptop with Pentium 100, ISA- and VL-Bus, 2
> PCMCIA-Slots Goldstar LPNCII-10/100 PCMCIA "Realport PC Card": Ethernet
> of course. Should work with the 8390 or pcnet_cs or both modules.

Both are needed, pcnet_cs depends on 8390.

> This is my problem:
> "ifconfig" doesn't list eth0.
> "/etc/pcmcia/network start eth0" prints "usage: network [action] [device
> name] ...".
> pcmcia-cs doesn't seem to load any modules if the card is plugged,
> although the "beeps" for connection and ejection are hearable.
> Even if the modules are loaded by hand, no eth0 appears in the system.

First guess: Cardbus PCMCIA card in a non-Cardbus compatible system? Your 
laptop appears to be an older model.

Second guess: probably your card does not get correctly recognized as 
ethernet device, most likely due to a missing entry in /etc/pcmcia/config?

What's the output of "lsmod" and "cardctl ident", "cardctl status", 
"cardctl config"? This should give you hints on how to construct an entry 
in /etc/pcmcia/config in order to bind pcnet_cs to your card.

After modifying /etc/pcmcia/config you will have to restart the PCMCIA 
subsystem with "/etc/init.d/pcmcia restart".

 Frank Trenkamp                     frank at trenkamp dot org
 GPG fprt: FF9E 9A3A CACB D840 6866  8485 DCB1 98FA 7162 4D9C

Reply to: