[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Longrun, gkrellongrun plugin for Crusoe CPU NEC laptop doestwork


Issue solved. I talked to one of the Developers, Nozomi Sato, and we got it 
resolved finally, after emailing back and forth for days. 

The developers of the package kindly updated their file, and uploaded it to 
the server. The URL is here:


There you will find the 2.2 version, which has to be compiled. Nozomi said, 
that the newer gkrellm have a different architecture that wont let 
gkrellongrun run. Now, they inserted a new patch, and with this, it will work 

Also, many new kernels (2.6.x) use a new 64 bit sys_pread system, so they need 
you to pass the following command instead of make





I have a NEC UltraLite Crusoe laptop and I run an up-to-date Sarge on it. 
Everything works right, Longrun included. However, I would like to monitor 
the Longrun status at all times, and found the Gkrellongrun package. So I did 

apt-get install gkrellongrun which installed the package and the GKrellM as 
well. GkrellM starts fine, but the plugin wont load for some reason. I 
googles my tail off, but have not found a solution yet.

When I go to the GKrellM preferences, and plugins beneath that, I dont see 
anything. So I go to the install logs, and the following error awaits me:

 Error: /usr/lib/gkrellm2/plugins/gkrellongrun.so: undefined symbol: 

I dont know how to follow through. I would love to see the Mhz the CPU is 
running at all times.

The cpuid and msr devices are readable writable at what the package's 
maintainer suggest on the website.



Reply to: