[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: inspiron 5150 and 2.4.24 kernel

Hash: SHA1


i have an Inspiron 5150 and had 2.4.24 running some time ago. ACPI did
not work properly, even with the acpi-patch applied. For
usb-mouse-support, i used discover and it worked all fine (assuming that
you have enabled usb-support and loaded all necessary modules).

Meanwhile, i upgraded my bios to the latest Dell-version, and i fear
that something went wrong with the dsdt in that version as the new
kernel (2.6.1) doesn't read the performance-states correctly.  After
all, i got acpi (or cpufreq) working with 2.6.1 and cpufreqd. When not
using multimedia-stuff extensively, i got a battery-runtime of
approximately 4 hours which is longer than under windows.

For further questions, don't hesitate to contact me.

Hope that helps,

PS: In case you do not upgrade and get 2.6.1 working, it would be nice
to inform me if the performance-states are read correctly.

slaven peles wrote:
| Hi,
| Did anybody manage to compile a working 2.4.24 kernel for Inspiron
5150? As of
| version 2.4.23 I was not able to compile kernel and have acpi and usb
to work
| properly. USB mouse doesn't work at all, and processor fan works at
| speed all the time. I tried with my own kernels and debian precompiled
| but the same problem persists. Kernel 2.4.22 works perfectly.
| Another thing -- my BIOS is A01, and Dell suggests upgrading to A29 or
| something version. I've read some reports that BIOS upgrade affects linux
| performance badly. Does anybody have experience with this for Inspiron
| Many thanks,
| Slaven

- --
"Everyone's worried about stopping terrorism. Well, there's a
really easy way: Stop participating in it."
~                                                  Noam Chomsky

| Dirk Reiss               |    phone:  ++49 (0) 531 7996276 |

| Helmstedter Str. 134     |    mobile: ++49 (0) 162 8925618 |
| D - 38102 Braunschweig   |                                 |
| Germany                  |                d.reiss@tu-bs.de |
Version: GnuPG v1.2.3 (GNU/Linux)


Reply to: