[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wireless glitch


I'm fairly new to Linux and have installed debian woody release 2 on my notebook. Just about everything works now except for one annoying glitch. I connect to the internet using an orinoco gold wireless pcmcia card and a wireless router that acts as a dhcp server. To connect to the internet I have to enter two lines of dns numbers from my isp in /etc/resolv.conf, but every time I reboot--or sometimes even during the same session--I need to reenter the dns numbers in /etc/resolve.conf because the settings are somehow being automatically overwritten. I can't connect to the internet without reentering the dns numbers, which gets tedious. This is about the only thing preventing me from using debian full-time. I've used nano, gedit and bluefish to edit the file after switching to root, all to no avail.

Here's what the /etc/resolv.conf  file looks like before editing:


I add these two lines with nano in a root terminal in a root kde session (also tried in root terminal as normal user):

After saving the file I'm able to connect to the internet, but after a short while those two added lines just disappear and I'm left with the original /etc/resolv.conf file and I can't connect to the internet unless I reenter the two dns lines.

I wish I could solve this because it's preventing me from using debian full-time.



Reply to: