[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wireless glitch

On January 24, 2004 04:42 pm, Tim Folger wrote:
> Hi,
> I'm fairly new to Linux and have installed debian woody release 2 on my
> notebook. Just about everything works now except for one annoying
> glitch. I connect to the internet using an orinoco gold wireless pcmcia
> card and a wireless router that acts as a dhcp server. To connect to the

A dhcp server may well update /etc/resolv.conf (or rather, your dhcp client 
can do that based on what the server tells it).  How long do you get on the 
DHCP lease?  It shouldn't be too hard to tell if that's what's happening, as 
syslog will note when you acquire a new  lease.  Where is, anyway?  
It's a private IP address, so I'm guessing it's either your machine or your 
router.  So either fix your DHCP client config, or your router config so that 
it sends the correct addresses.

My best guess is that your laptop is configured correctly, but your router is 
misconfigured to either send the wrong DNS IP or it is supposed to be caching 
DNS queries but hasn't itself been configured to find a DNS.

If you _do_ want to fix it at the client end:

> Here's what the /etc/resolv.conf  file looks like before editing:
> search
> nameserver
> I add these two lines with nano in a root terminal in a root kde session
> (also tried in root terminal as normal user):
> nameserver
> nameserver

"Add" or "replace"?  If doesn't work, you don't want it in there, 

Depending on your dhcp client, you should have a file in /etc that configures 
what info is requested from the server.  In the case of dhclient (which is 
what I use) it's /etc/dhclient.conf and it contains something like:

request subnet-mask, broadcast-address, time-offset, routers,
            domain-name, domain-name-servers, host-name;

Or that line may be commented out, in which case I _think_ it gets all of 
those.  So you'd want to replace it with lines not including 
"domain-name-servers".  The other DHCP clients should all have something 

Another possibility is that you have resolvconf installed (and misconfigured) 
in which case the values in /etc/network/interfaces are wrong.

Reply to: