[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation on Compaq Presario 1245

Thanks for everyone's help thus far.

This morning, I was able to get a PCMCIA network card for this machine
(3Com - 3C574-TX).  And, this is where I've gotten:

I boot with the Rescue disk and load the Root disk.  Then I configure
PCMCIA devices.  This enables Network configuration.  I enter my proxy
info and it starts downloading base system files.  It retrieves and
validates many *.deb files.  When this completes, it starts extracting
the base system.  It then start installing/configuring, and I get the
following error message:

Failure while installing base packages.  This will be re-attempted up
to five times.

After it retries five times:

Base Installation Error
debootstrap exited with an error (return value 1)

Seems like I'm getting very close...  I tried a different mirror
(mirrors.kernel.org) with the same results.

I also tried downloading the new (beta) debian-installer, but I could
never get the networking to work properly using that.

Any other suggestions?



>>> Osamu Aoki <osamu@debian.org> 1/13/04 4:15:02 PM >>>
On Tue, Jan 13, 2004 at 03:58:16PM -0600, Robert Aldridge wrote:
> Hello list...
> I'm attempting to install Debian (Stable) on a Compaq Presario 1245.

Welcome :-)

> The CD-ROM isn't working properly, so I'm installing via floppies. 
> followed the instructions using the Rescue, Root, 4 driver disks, and
> base-install disks and successfully got it installed to the 3.2 GB
> harddrive.  

You should get network card or serial line PPP to do most of install.
I think few boot floppy is all you need if you have another networked

> But, I can't get it to boot.  I have the HD (hda)
> partitioned into 3 partitions, /dev/hda1 is to be mounted on /boot
> MB), /dev/hda3 (~3.1 GB) is to be mounted on /, and 128 MB at the end
> the drive is configured as Swap.  I got through the entire install
> when it asked if I want to make the system bootable, I chose the
> alternate (Make a boot floppy).  After the boot floppy is created, I
> chose the "Make the system bootable" menu item and wrote LILO to the
> MBR.  After rebooting, the red LILO screen comes up with 2 options,
> "Linux" and "Linux (hda1)."  The arrow keys don't appear to do
>  If I let LILO timeout and try to boot the default entry, it just
> recycles and starts counting down from 15 again.


> If I boot with the rescue disk and type "rescue root=/dev/hda3", the
> system appears to be coming up normally, but hangs.  The last two
> on the screen are:

This means you have lilo not working.

> VFS: Mounted root (ext2 filesystem) readonly.
> Freeing unused kernel memory: 152k freed
> Then it just sits there.  Nothing else happens.
> When I try booting from the boot floppy, it says "Loading
> linux.bin........." for a very long time (several minutes) and then
> says, "Uncompressing Linux...
> After a couple of minutes, it says, "invalid compressed format

Looks like your initd may be not configured well.

  * Which kernel image did you installed.
  * Do you have initrd="..." line in /etc/lilo.conf
  * Did you run lilo after editting /etc/lilo.conf
> On a side note, I think the CD-ROM drive is bad, but I'm wondering
> it may be IRQ conflicts or something.  Please help if you can.

Could be.  Did you installed other OS.  RH, Knopix, Mandrake, ...

Debian's auto hardware support is not the best but you can always
manually fix it.

To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact

Reply to: