[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Weird X problem

On Sat, Sep 06, 2003 at 12:23:31PM -0400, David Z Maze wrote:
> David Fokkema <dfokkema@ileos.nl> writes:
> > Anyway, I've got an ATI Radeon 9000 Mobility (ATI Radeon Mobility M9 Lf
> > (AGP)) with a Samsung LTN150P1-L02 TFT panel at 1400x1050.
> >
> > When I start X, I only get a black screen on my panel.
> Which X are you using?  I needed to go to XFree86 4.3 for my Radeon
> 9000 Mobility.  I did this by getting binary tarballs from xfree86.org
> (Xxserv.tgz and Xmod.tgz), and unpacking them in /usr/local, and
> repointing /etc/X11/X and editing the paths in XF86Config-4.

I'm running X 4.3 from experimental. Without it, the radeon 9000 isn't
even supported: no device candidate, resulting in 'no screens found'.

> > What _does_ work, however, is starting X while making sure that _no_
> > external monitor is connected. I get a black screen. Then, plug in the
> > monitor and switch between TFT/CRT twice. If I'm fast enough, my monitor
> > doesn't even come up (it doesn't support 1400x1050 anyway) but my laptop
> > panel does. I then have a fully working DRI enabled set up and can play
> > tuxracer, chromium, view DVDs, etc.
> ...but I think there's a DRI version incompatibility with the newer X,
> so you'd need a kernel-side DRM newer than what's in any released (2.4)
> kernel if that's important to you.

I have downloaded drm-trunk-module from Michael Daenzer's apt repository
and DRI is fully functional now: checked my logs which said 'Direct
rendering enabled', checked glxgears with and without dri, ran tuxracer
and chromium, etc.

It's just that the panel doesn't come up by itself.


Hi! I'm a .signature virus. Copy me into
your ~/.signature to help me spread!

Reply to: