[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Weird X problem

Hi group,

I didn't know what to put in the subject header...

Anyway, I've got an ATI Radeon 9000 Mobility (ATI Radeon Mobility M9 Lf
(AGP)) with a Samsung LTN150P1-L02 TFT panel at 1400x1050.

When I start X, I only get a black screen on my panel. I tried
everything I could think of, but it doesn't work. Using vesafb and fbdev
works up to 1400x1050x16, but that's it. I disabled vesafb completely
(compiled a _lot_ of different kernel versions) but that didn't work.
Radeonfb doesn't work (I only get a garbled screen, even for vga=normal,
in which I see parts of tux flying by) either. Totally disabling the
framebuffer and using the ati/radeon driver doesn't work. Giving the
modeline found with vesafb @1400x1050x16 but not using the framebuffer,
does not work, etc.

What _does_ work, however, is starting X while making sure that _no_
external monitor is connected. I get a black screen. Then, plug in the
monitor and switch between TFT/CRT twice. If I'm fast enough, my monitor
doesn't even come up (it doesn't support 1400x1050 anyway) but my laptop
panel does. I then have a fully working DRI enabled set up and can play
tuxracer, chromium, view DVDs, etc. However, if I exit X, I have to
unplug the monitor, etc. I haven't tried suspending...

Of course, I tried to run xvidtune to get the sync frequencies, but the
graphical screen tells me the dot clock, as well as the sync
frequencies, are all zero. On the command line, it blurts out the values
specified by me in the modeline, which may actually be correct (how
would I know?) but don't enable the panel (since I need the external
monitor trick).

How on earth can I enable my TFT panel? How do I find out the sync
values? Is that the problem or is there something with the radeon
driver? The 9000 reportedly works on many systems, but not on this
specific panel (I found more with trouble using google, one with the
external monitor trick, none with a working setup). Also, the X log says
at one point "Using BIOS provided dividers" (for res 1400x1050). Could
that be a problem? Should I update my BIOS? Samsung doesn't have
datasheets with the information I seek, maybe I should drop them a mail?
Also, read-edid doesn't work on my panel (call failed). Is this a

Sorry for the length of this mail (at least I didn't attach all my logs,
;-) but I'm completely at a loss here...



Hi! I'm a .signature virus. Copy me into
your ~/.signature to help me spread!

Reply to: