[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: printing to cups server from openoffice

    "Michael" == Michael K O'Brien <Michael> writes:

    Michael> Hola~ I have a Mac with an Epson Stylus 880 installed. I
    Michael> have a laptop with unstable installed. I set "ServerName"
    Michael> in /etc/cups/client.conf to point to my mac. If I run
    Michael> "lpr someTextFile.txt", it prints fine. However, trying
    Michael> to print ps, pdf, or from openoffice is greeted with
    Michael> silence.

    Michael> For example, if I run "lpr a.ps". The error log on the
    Michael> Mac server says:

    I [] Job 88 queued on 'Sylus_COLOR_880' by 'mobrien'.
    E [] Unable to convert file 0 to printable format for job 88!

    Michael> Is the problem with the Linux box or the Mac? How does
    Michael> one convert post script to a printable format?

Well, I'm not sure if this will help, but here goes anyway....

I had a similar problem in the other direction. Printing from my Mac
to my Debian Woody box did exactly the same thing. So, on my Debian
box I had to edit /etc/inetd.conf to say

printer stream tcp nowait lp /usr/lib/cups/daemon/cups-lpd cups-lpd \
   -o document-format=application/octet-stream

to force cups to figure out the type correctly.

Perhaps this gives you the clue you need on the Mac.....here's
hoping. It's my wife's Mac, so I tend not to hack it too much even if
it is a BSD box.....

Now if I could just get the Mac to treat my Debian box as a real cups
server. I seem to be able to print to it merely as an lpd
device. Aaargh.... 


Reply to: