[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: autoloading module for pcmcia network card

> After I finally broke off the adaptor-cable of my old network-card, I
> now have a new noname 8139-based one.
> Problem is, that the cardmgr can find and activate the card, but does
> not load the required modules or start the interface. The card works
> just fine, if I modprobe the 8139too-module and configure the
> interface by hand, but I'd rather have this happen automatically, like
Same here. Problem was, I wanted to install through the network :-((

BTW, did you find the modules for the 2.4.28-bf24 kernel ? I'm still
missing them !
I had to recompile the modules AND the kernel 'cos it was complaining
about version mismatches between modules (2.4.28) and kernel
(2.4.18-bf24). Shouldn't kernels now be able to handle modules from
other versions ????????

> I tried adding the following lines to /etc/pcmcia/config:
> device "8139too"
>   class "network" module "net/8139too"
> card "NoName 10/100"
>   manfid 0x10ec, 0x8139
>   bind "8139too"
> but obviously those don't do the trick.
also tried with different parameters (like function, ID's ...)

btw, "NoName 10/100" and "8139too" are just ID strings and have no
real-world meaning (as stated in a previous mail)

> How do I get the cardmgr to automatically load the 8139too-module and
> set up eth0 (this is debian/testing, kernel 2.4.20)?
I read the docs about cardmgr and found that for 32-Bit card, they
recommend using hotplug AND removing cardmgr !
Did this... did NOT work !
had a look at the script : it looks for /etc/hotplug/*.rc and executes
each one with the parameter start|stop
and if you look at the directory, there's only an usb.rc !!
so I created a pcmcia.rc by copying the usb.rc script, removed what was
not required, and put in the start section : modprobe 8139too
(and in the stop : rmmod 8139too)

works perfect for me.

But all this handwork makes me doubt that this is the 'offical' (tm) way
of doing this !


Reply to: