[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sound/alsa on thinkpad

Dear all

Thanks for earlier comments on this.  I installed Alsa and tried a few
things.  Sound still not working.  Below are some messages from my machine
(a Thinkpad A31p).  Any cluebits re alsa installation or the error messages
from alsaconf would be much appreciated.

* The sound card is an Intel Corp. I82801CA/CAM AC'97 Audio (as detected by

* Installing alsa: seemed to require (a) a 2.4.16 kernel image, and (b) that
I add 'initrd=/initrd' to my lilo.conf.  Can't it work with the 2.4.18
kernel already installed?

* Running alsaconf:

debian:~# alsaconf
Initializing ... please wait ...
modprobe: Can't locate module snd
cat: /proc/asound/version: No such file or directory
expr: syntax error


chose 0x31 Intel_i810/810E, i820, i830, i840, MX440

Max. playback frame size in kB (4-128) ...?
Max. capture frame size in kB (4-128) ...?
Max. microphone frame size in kB (4-128) ...?


Loading driver:
No ALSA driver installed
Starting ALSA sound driver (version none):modprobe: Can't locate module snd
Setting the PCM volume to 100% and the Master output volume to 50%
No ALSA driver installed
Could not initialize the mixer, the card was probably not detected

- module snd: I don't have this (don't remember it being listed) but I do
have the following sound related modules:

Module                  Size  Used by    Not tainted
sound                  52876   0  (unused)
i810_audio             21248   0  (unused)
ac97_codec              9568   0  [i810_audio]
soundcore               3236   4  [sound i810_audio]

If I have to add extra modules to the kernel, do I have to reinstall or can
I do it piecemeal (e.g. with insmod)?

- /proc/asound/version: Don't know what asound is or why it should be there.

- frame sizes: can anyone provide a good default for these?

- No ALSA driver installed: should an alsa driver be set up before running
alsaconf, and if so how?



Reply to: